December 20, 2010

Wikitude Drive: Supported Handsets

Wikitude Drive has the following hardware and software requirements:
OpenGL >= 1.1, Android 2.1 oder 2.2, 700Mhz or more
Due to the high system requirements of Wikitude Drive, every model of Android smartphone/tablet must be individually tested to assure ultimate performance. The following smartphones/tablets have already been successfully tested:

Questions, comments? Let us know!

If you have questions, suggestions or feedback on this, please don’t hesitate to reach out to us via Facebook, Twitter or send us an email at hello@wikitude.com!

Contact us
Share

More Blog Posts

September 6, 2019

Back To School: Get Started With Augmented Reality NOW!

August 22, 2019

Geo AR: Location-based Augmented Reality Use Cases and How-to

Subscribe to our Newsletter

Stay up to date with the latest Wikitude news.

Subscribe now

August 14, 2019

Wikitude SDK 8.7: new UWP feature, Extended Image Tracking range, and AR platform improvements

July 16, 2019

Wikitude SDK 8.6: HoloLens + Flutter Plugin + Geo AR for Unity

June 27, 2019

Augmented Reality Demo with Simultaneous AR Tracking: Object + Image + Positional

June 13, 2019

Augmented Reality SDK for Microsoft HoloLens